Page 1 of 1

So i think my TPS is bad

Posted: Sun Jun 07, 2009 8:40 pm
by 7angofragger
Just got the car an it has always drove weird at low rpms.. So I plug up my scanner and check my data.. Off the pedal the tps is reading 15.2, and WOT it's reading 77.4.. Is this normal for srts or should I replace it?

Re: So i think my TPS is bad

Posted: Mon Jun 08, 2009 5:55 am
by I8yourVtec
I personally dont know if its normal but SRTs are famous for TPS problems. The problem is usually a broken wire inside the insulation. The design was stupid. Anyways, you can go to www.turboneonstore.com and order the TPS repair kit. Its only $22 or so.

Re: So i think my TPS is bad

Posted: Fri Jun 12, 2009 7:25 am
by Dustinsuglyhighline
77% and up is considered WOT. 15% is close enough to idle. PCM should've adjusted to it though.

Maybe have a vac leak?

Re: So i think my TPS is bad

Posted: Fri Jun 12, 2009 11:35 am
by 7angofragger
prolly....i need to do a leakdown...

Re: So i think my TPS is bad

Posted: Sun Sep 06, 2009 10:59 am
by buggy1
:mad: ive got 24 1st gen that has exat promblem 14 percent fully closed n 80 percent wot i changed tps then old throttle body all same readings but it goes into open looop at wot like suppost to ive been tryin to see if it ok plz post when u figuer out

i think dustin is right the ecm adjust to it but if so why does scanner change also it buggs me cause if it was just not readin wot i could adjust tps with slots by bolts but its not readin closed either WTF MAKES HULK MAD GRRRRRRR ME SMASH

Re: So i think my TPS is bad

Posted: Sun Sep 06, 2009 9:08 pm
by Hi-Def
I8yourVtec wrote:I personally dont know if its normal but SRTs are famous for TPS problems. The problem is usually a broken wire inside the insulation. The design was stupid. Anyways, you can go to http://www.turboneonstore.com and order the TPS repair kit. Its only $22 or so.
yes , its a common problem for SRTs mainly.